4

I have a view that includes bulk operations that involve flagging (Flag module) or unflagging nodes. I originally created this in Drupal 6 for another site and have been using it for several years. I recently re-created this in Drupal 7 whereby four different bulk operations can be carried out in a view on a specific type of node. This works flawlessly for administrative users. Authenticated users, however, cannot see the four "operations" buttons in the view I've created.

I've checked permissions everywhere, even "loosening" them to see if they were too tight. For example, I granted "Edit any node" permission to authenticated users, even though they shouldn't need that for the flag action. I've checked the view permissions, etc.

The operation calls a simple flag or unflag action and I'm unable to find any other permission(s) that might be impacting this. I'm hoping someone's going to jog my memory with something simple I've missed.


Edited to add: I have a similar view on the same site that allows users (through VBO) to send an email to multiple users. They're able to see the button for this functionality just fine. Again, leading me to believe this is a permissions issue.

  • Searching 'vbo permission' on the issue queue for the flag module brings up this: drupal.org/node/2177577 – Darvanen Jan 5 '15 at 4:19
  • That is one of the many threads I read that ultimately suggested using Rules rather than addressing the permissions issue directly. – Rob Jan 5 '15 at 18:14
2

You need to install the sub module in VBO called Actions Permissions.

ACTIONS PERMISSIONS

A module called actions_permissions is included in the package. This module generates a permission for each action, and VBO honors those permissions before showing or executing the corresponding actions. This is useful if you want to provide your VBO to several groups of users with different privileges: the same view will accommodate those different groups, showing to each the actions that they are permitted to see.

For your view make sure that you add the relationship to the flag

enter image description here

something like this (adjust as appropriate)

enter image description here

Afterwards navigate to the permissions screen, and enable Execute Flag (or unflag) a node for your roles

enter image description here

For your view of content you need to add the field Bulk Operations: Content (NOT bulk Operations:Flag').

enter image description here

And last but not least, make sure your flag permissions are set for your roles.

  • Thank you for this excellent and thorough answer. Sadly, it didn't fix it. As soon as I read it, I was sure it would (Why didn't they put the actions permissions module in the Views/VBO section???). But it changed nothing. I activated the module, checked the permissions. Confirmed that I was using Bulk Operations: Content (the flag one doesn't even appear as an option for me), quadruple checked the permissions of the flags I'm using, and still no love. !Action Perms !Flag Perms !View – Rob Jan 5 '15 at 18:46
  • Obviously I've failed a posting them inline, but here are two more. The first showing what an admin sees. The second showing what an auth user sees and also confirming they've been able to check the flag on the node page: !Admin View !Auth View BTW, when I made the changes, I also cleared the cache multiple times. – Rob Jan 5 '15 at 18:54
  • FYI, I've bitten the bullet and set this up through Rule components and it's working. I still wish it worked the "simple" way and am curious to know if there was something I was missing, but will have to leave that for another day. Thank you! – Rob Jan 6 '15 at 2:17
  • Next time make sure that you bring in the relationship to the flag into the view. I'm pretty sure you did not. It will also then bring in a flag/unflag field for you to add to your view – J. Reynolds Jan 6 '15 at 3:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.