1

I am getting the following message while submitting the message.

There was an error 401 from Twitter. Visit Twitter HTTP Status Codes page to understand what is going wrong.

I don't find where I am wrong? Anything specific I am missing in twitter setting?

I have set all the tokens correctly. Attaching screenshot below :

enter image description here

2

I tried the module and it works fine. Follow these steps to enable auto posting to Twitter.

  1. Go to https://apps.twitter.com, and click "Create New App". In Application Details, enter the name of the App, enter some description, in website enter http://example.com, leave callback URL empty.
  2. Agree with the user agreement after reviewing it, and click "Create new app".
  3. Go to "Keys and Access Tokens" tab.
  4. Please make sure you give "Read, write, and direct messages" access level to the app.
  5. Click on generate the Access token. Keep this page open.
  6. In a separate tab open http://example.com/admin/config/services/publish-away after logging in as admin.
  7. Enter "Consumer key", "Consumer secret key", "Access token", and "Access token secret" from the app.
  8. Hit Save. The account should now appear under the "Accounts" section.
  9. Create new content of type news for testing, check the "publish to Twitter" checkbox, and save.
  10. The article's link should get Tweeted by your Twitter handle.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.