0

I installed SMTP module for Drupal 7. I enabled it and press Settings button to go to Settings menu. But there is no Setting menu there... How to reach it?

3 Answers 3

0

The SMTP module configuration page is at admin/config/system/smtp.

Make sure that you have the permission change the SMTP configuration.

7
  • The problem is that I do not have such page. I checked permissions - all is OK for admin.
    – user38998
    Jan 5, 2015 at 20:27
  • Are you using D7 ? What version of the SMTP module are you using ? Did you try clear the caches ? Jan 5, 2015 at 20:30
  • Yes, it is Drupal 7. I tried both vertions - stable and dev. I cleared cashes.
    – user38998
    Jan 5, 2015 at 20:50
  • Do you have any logs ? From admin/reports/dblog. Jan 5, 2015 at 20:52
  • 1
    @user38998 We can't have idea why without knowing your view. Conflicting paths, maybe?
    – Mołot
    Jan 5, 2015 at 21:32
0

It was error in Views page - conflicting path. To find it I checked report page. After fixing this problem, Settings menu for SMTP module appeared.

0

Step 1: Download SMTP module and enable it.

Step 2: Go to Admin > Configuration > System > SMTP authentication support and set the following values:

  • Turn this module on or off: On.
  • SMTP server settings:
    • smtp server: smtp.gmail.com
    • smtp backup server: leave blank.
    • smtp port: 465
    • use encrypted protocol: select "use SSL"
  • SMTP authentication:
    • Enter a valid Gmail email address and password.
  • Email options:
    • Set the same email address that you used at SMTP Authentication.
  • Send test email: set an email to receive a sample email and to test whether the module is working.
  • Enable debugging: yes.

Step 2a(Optional): Allow Less Secure Apps Access which is here: http://www.google.com/settings/security/lesssecureapps

Step 3: Click on Save and go to your inbox to check. If there is an testing email then it is fine.

Note: Your email address provided in your smpt setting MUST be the same like in your site information.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.