0

I have a site "damo1.com" now I want to use my drupal site in "damo.com", so I just change $base_url in sites/default/settings.php. And I still can see my homepage very good, but I cannot check the others views or access to the site as user.

Do I need to do one more step? Thx

2
  • We can't quite know how are your servers and domains configured. Also, "cannot check the others" is broad. What exactly is happening? – Mołot Jan 10 '15 at 17:14
  • I couldnt check all my "views" but now its working – DarkteK Jan 12 '15 at 0:45
1
  1. In your sites/default/settings.php file, comment the $base_url line, you don't need to specify one, Drupal can do it for you.
  2. In your .htaccess, uncomment RewriteEngine on
  3. In the same file, RewriteBase / must be also uncommented, and if your website is hosted under a subfolder of your root web folder, you must specify your folder here. Eg: RewriteBase /subfolder/
  4. Activate clean URL's in admin/config/search/clean-urls
  5. In apache httpd.conf file, check if mod_rewrite is enabled
0

try to remove $base_url from your settings.php ? Drupal is supposed to guess correctly your base url in your situation.

0

Before migrate your site I/You needed to:

Disable clean URLs in the live site - » Administer » Configuration »Clean URLs, disable and save.

Then in my/your new site enter with this:

?q=admin/config/search/clean-urls

And activate again Clean URL's, with this my/your site will reconize the clean url's

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.