2

I have just installed Drupal 8 development version (drupal-8.0.x-dev) but while running it on my web server I am getting this error:

Parse error: syntax error, unexpected '[', expecting ')' in C:\xampp\htdocs\drupal-8\core\vendor\react\promise\src\functions.php on line 62

Line 62 has code:

59   return resolve($promisesOrValues)
60          ->then(function ($array) use ($howMany) {
61              if (!is_array($array) || !$array || $howMany < 1) {
62                  return resolve([]);
63              }

My PHP version is 5.3.8

Is there anybody else who has faced same issue?

10

Drupal 8 requires PHP 5.5.9 or higher (for short array syntax among other things).

You'll need to upgrade your version of PHP.

Source: System Requirements

  • yeah thats correct I missed that part... – Ashish Bairagi Jan 7 '15 at 10:12
  • 2
    That's correct, but the installer should tell you so instead of a fatal error. There's probably already a bug report about this, but would be great if you could check and report this if there isn't. – Berdir Jan 7 '15 at 20:22
  • actually this error appeared just you hit localhost/drupal8 it even don't let you go to installer will check and report this bug. – Ashish Bairagi Jan 8 '15 at 6:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.