0

I'm migrating my Drupal website to a new host.

Here's what I've done:

1 - Create an DB.mysql.gz using backup and migrate module (in old host)

2 - Create a new database and user in new host and restore this DB.mysql (step 1) directly using mysql -u USER -pPASS MYBD < /home/DIR/DB.mysql

3 - Install in new host the drupal using QuickInstall (installed v7.32)

4 - Transfer all data by directory www (old host) to a new host (hostgator - public_html) overhidding all files of Drupal 7.32 (installed by QuickInstall) to my current install v7.34.

5 - Change settings.php database content

I need check if all site is running OK before change DNS, for it, i need login using www.URL_TEMP/~MYUSERHOST/user/login, but this URL return 404 - Page not found.

Home page is load disfigured and browser log say 404 not found in css/js files, eg: www.URL_TEMP/~MYUSERHOST/sites/default/files/css/css_xE-rWrJf-fncB6ztZfd2huxqgxu4WO-qwma6Xer30m4.css and others. This file exists in public_html/sites/default/files...

I try change hosts file in my local machine (http://support.hostgator.com/articles/general-help/technical/how-do-i-change-my-hosts-file) but not solved.

This problem does not allow that I access with admin and change file temporary path in /admin/config/media/file-system, clean cache and test website.

Am I missing something, or do something wrong?

Ps: In old host the website is running OK!

  • 1
    You need to clear the cache, and if the existing temporary file path is invalid you'll need to change it. – Clive Jan 7 '15 at 13:05
  • For it I need login with Drupal Administrator using www.URL_TEMP/~MYUSERHOST/user/login but it return 404 error :) – vctlzac Jan 7 '15 at 13:06
  • 1
    If you're using DB caching (likely if you're on shared hosting), you can truncate the cache table, and any others who's name begins with 'cache_' to get the same effect. Also check the $base_url in settings.php is sensible. As a temporary measure you can add $conf['file_temporary_path'] = '/path/to/real/tmp/folder'; to settings.php to unconditionally override the tmp location – Clive Jan 7 '15 at 13:08
  • I changed base_url to URL_TEMP/~MYUSERHOST and add $conf in settings.php but no success :( – vctlzac Jan 7 '15 at 13:29
  • Add $conf['cache_lifetime'] = '60'; in settings.php. No success again – vctlzac Jan 7 '15 at 13:39
0

If you are sure that settings.php and ftp files are all set right, my guess is you miss some package in php or in appache. Please compare php and appache settings between old host and new host. For example, rewrite_module in apache

0

I add RewriteBase /~MYUSERHOST in .htaccess and solved problem!

I can now logging using URL_TEMP/~MYUSERHOST/user/login. I'm testing website, but initially everything is ok.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.