I got a XML import witch imports new nodes, in this nodes there is a node reference field. When I run the import I get the message "does not match an existing node" when I look at the nodes they got the node reference, but when you edit the field is empty.

If you look in the database I see that language stays on UND when I change this and update the database it works but when the import runs again its ruined again.

Any solution?

  • turned off the translation on the node reference with entity translation. this fixed the problem for me. Commented Jan 16, 2015 at 9:46
  • @Pierre.Vriens done! Commented Aug 3, 2017 at 10:05

2 Answers 2


The issue you have run into looks like it may be identified here: https://www.drupal.org/node/1183440. I walked through this issue queue and was able to get my feed processor to specify the language it was importing. The comment #193 was particularly useful. I'll elaborate on his directions a little bit.

For the record, this patch applies only to the feeds module, but you will need to have Feeds Entity Translation installed as well (which you probably already do).

  1. drush dis feeds -y
  2. rm -rf feeds - remove feeds directory entirely
  3. git-pull the feeds repo and checkout older commit:

    git clone --branch 7.x-2.x http://git.drupal.org/project/feeds.git

    cd feeds

    git checkout 006234fc3cc859e4fec0cb261675577efcf389b8

  4. enable all feeds modules that were disabled from step 1:

    drush en feeds, feeds_ui, feeds_tamper, feeds_tamper_ui, feeds_et, feeds_ex -y

  5. patch feeds:

    wget https://www.drupal.org/files/issues/feeds-field_translations-1183440-191.patch

    git apply < feeds-field_translations-1183440-191.patch

  6. confirm patch by building new feed. you should see a language option under the processor settings.

There is a little bit of work to do on this patch before it can be incorporated in the Feeds trunk, but I'm hopeful it will be in place within a few months.

  • I turned off the translation on the node reference with entity translation. Now it works like i want it to be Commented Jan 14, 2016 at 10:48
  • wilcocammeraat can you please post the path of the settings.
    Commented Mar 10, 2016 at 6:04

I turned off the translation on the node reference with entity translation; this fixed the problem for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.