In "Administration > Structure > Menu," I disabled the "My account" link, but the theme is still showing it.


I took the screenshot after disabling the link, closing the overlay, and clicking the "reload" button of the browser; still the link is show, even if it is disabled.
Why is it happening?

If I disable the "Log out" link that doesn't appear anymore.


Why is the "My account" link so special? More importantly, how can I disable it?


I could disable it by clicking "edit" and then unchecking the "enable" box.

  • I was disabling it from the page that I have shown in the screenshots, and it was not working. I didn't think of disabling it from the edit page; I took that the effect should have been the same. – kiamlaluno Oct 29 '11 at 17:36

This is a known bug and is already discussed a lot:



Quick fix would be to create a new menu and add that in your template.


In my case the menu item of the user profile was always marked as disabled in the settings. As administrator I could always see the menu item on the front end, other users could never see it. In this answer I found a workaround with the module menu_token and setting the path to user/[current-user:uid].

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.