3

When I ran drush sql-dump --result-file, it came back with a warning and a success message.

system(): Cannot execute a blank command exec.inc:36                 [warning]
Database dump saved to                                               [success]
/my/homedir/drush-backups/unknown/20150113014628/_20150113_014628.sql                      

However, I checked inside the directory and no .sql backup file can be found. I have also read this issue, but I am not using drush aliases.

How can I fix this and backup my database using the command line?

  • try running the same drush command with --debug to see more detailed system issues you may be experiencing. – tenken Jan 13 '15 at 2:12
  • Thanks for the tip. But my colleague has figured it out now. – dayuloli Jan 13 '15 at 2:18
2

I was following the docs, which told me to execute the command in my 'From your Drupal directory', so I executed the command on my Drupal installation root directory.

I have a multi-site set up, and running it inside my site directory /sites/mysite/ worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.