0

I installed Debian 7 in a VM, there is nothing there except for web server apache2, mysql, webmin, phpmyadmin, and drush.
Drush fails to install Drupal, gives me admin and password but it fails to log me in.
Error: Not Found
The requested URL /phurst/node was not found on this server. Apache/2.2.22 (Debian) Server at xx.xx.xx.xx Port 80
Weird thing is that it works flawlessly on my localhost, my computer is more advanced, I use Debian testing branch in it. I cannot figure out what is causing this, I added my user to group www-data, chowned web root (/var/www) to myuser:www-data.
I noticed that perms were not set, that is weird because drush set perms correctly, I set all perms on the site to 775 recursively, but I am still locked out of the admin area.
Another weird thing: I can install Drupal manually, but I need to use drush to go fast. Thanks in advance.

  • Have you tried using the non-clean URLs to access the site? See if you can login from /phurst/?q=user – filmoreha Jan 14 '15 at 2:06
  • The requested URL /phurst/user/1 was not found on this server. That is what I get when using non-clean – ckosloff Jan 14 '15 at 3:14
  • What happens when you go to /?q=admin/config/search/clean-urls – filmoreha Jan 14 '15 at 4:16
  • If you can get to that page, perhaps turn off clean urls and see if everything is working. Alternatively looks like you can use "drush vset clean_url 0 --yes" – filmoreha Jan 14 '15 at 4:18
0

Here is the answer to the riddle. My live VM is on an older version of Debian, different document root, different apache2.conf. It is much easier to edit apache2.conf in the newer version, and that is why it was working: Options Indexes FollowSymLinks

AllowOverride None

AllowOverride All
Require all granted

In older version, I copied apache2.conf to something else and replaced Deny for Allow, like so: Order allow,deny Allow from all Satisfy all . Completely different, I am mulling to move server to testing version, in spite that everybody advices against it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.