0

I need to create several nodes of the same type and all have to have an image carousel similar to what flexslider does in Views.
I already deleted the Views example but cannot replicate the behavior in a field in spite that I formatted the field with flexslider full, I just get the images displayed one below the other.

7
  • What version are you using? There was an issue with Fields and alpha 2. Commented Jan 15, 2015 at 6:55
  • I enabled flexslider with drush on a clean test site version 7.x-2.0-alpha3. I am getting following warnings in status report: Warning: fopen(sites/all/libraries/flexslider/jquery.flexslider-min.js): failed to open stream: Permission denied in _flexslider_requirements_library_installed() (line 212 of /var/www/html/dtest/sites/all/modules/flexslider/flexslider.install). Warning: fread() expects parameter 1 to be resource, boolean given in _flexslider_requirements_library_installed() (line 213 of /var/www/html/dtest/sites/all/modules/flexslider/flexslider.install).
    – ckosloff
    Commented Jan 16, 2015 at 16:07
  • Did you follow the installation instructions on the project page? I think the library is missing. Commented Jan 16, 2015 at 19:04
  • The library is there.
    – ckosloff
    Commented Jan 17, 2015 at 13:45
  • It looks like apache doesn't have permission to read sites/all/libraries/flexslider/jquery.flexslider-min.js. Did you check the file permissions? Maybe it's root only? Commented Jan 17, 2015 at 18:06

1 Answer 1

1

Check the following:

  1. What version are you using? There was an issue with Fields and alpha 2.
  2. Are the libraries downloaded to the correct location? Check the project page for instructions.
  3. If the libraries are there, does the webserver user have permission to read the libraries?
5
  • Your answer eliminates the warnings in watchdog, but flexslider is still not functional in the field, images are stacked. Perms on /sites/all set to 775 for all, including flexslider folder and libraries.
    – ckosloff
    Commented Jan 18, 2015 at 17:18
  • And still no errors in the console of your browser? Did you check 'Reports' -> 'Recent log messages'? Commented Jan 18, 2015 at 17:28
  • I don't understand what you mean by "the console of my browser". Yes, there were log messages but they were related to the above mentioned warnings, which were fixed.
    – ckosloff
    Commented Jan 18, 2015 at 23:50
  • The console in the browsers allows you to see errors and debug your website. More info: webmasters.stackexchange.com/questions/8525/… Commented Jan 19, 2015 at 6:19
  • paste.debian.net/141392 the flexslider function is too big to paste here, please use link. Thank you.
    – ckosloff
    Commented Jan 20, 2015 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.