2

I created an exposed filter for my View that aggregates user-submitted webform data. I was hoping this would allow them to search the View for specific webform entries. Unfortunately, the View remains unsortable by column (although I checked the option to make every column sortable), and whenever I search via my exposed filter, it comes back with 0 results.

I've attached images of my Filter and View settings... am I doing something wrong?

Thanks!

View Settings: View Settings

Filter Settings: Filter Settings

Table Settings: Table Settings

1

Check your FORMAT -> Format: Table | Settings for a checkbox that says Override normal sorting if click sorting is used and turn it on if it is not already.

  • Hi Darvanen, Thanks so much for your advice. I checked, and that checkbox is checked. I'll edit my post to show my Table Settings, too. Any further advice would be greatly appreciated. Thanks! – Casey Jan 15 '15 at 23:53
  • I wonder if the combined filter is interfering, maybe try removing that? – Darvanen Jan 16 '15 at 0:01
  • I thought that the exposed combined filter is what allowed the users to search? – Casey Jan 16 '15 at 0:08
  • Okay, interesting - I removed the filter, and yes, now the columns are sortable. Now, how would I get search functionality, too... – Casey Jan 16 '15 at 0:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.