I'm building a website related to videogames. There's a view that shows all videogames catalogued in the website, using taxonomy terms as arguments, that is:


The problem is that the "games" part in the URL is unnecesary: everything is games. For SEO reasons we want to remove this part, so, for example, this...


becomes this...


That is, a view with no fixed part in the path, just the parameters. How can I get this working?

  • If using the same view to drive the home page is an option you may be able to get away with changing the path to <front>
    – Clive
    Jan 16 '15 at 15:31
  • You can´t use <front> in a views path. Jan 16 '15 at 15:33

You can go directly in your View's settings, in "Page settings" bloc, configure the path manually. Just remove the game part of the path.

For your information:

I suggest you to take a look at Pathauto module that allows you to define URL patterns very precisely for all the default pages of your site (but not views apparently): https://www.drupal.org/project/pathauto

The Pathauto module automatically generates URL/path aliases for various kinds of content (nodes, taxonomy terms, users) without requiring the user to manually specify the path alias. This allows you to have URL aliases like /category/my-node-title instead of /node/123. The aliases are based upon a "pattern" system that uses tokens which the administrator can change.

Maybe it will be helpful for other cases.

  • Thanks, but this is not the problem. The problem is that my URLS have more than one dimension, that is: mysite.com/[taxonomy-genre]/[taxonomy-platform] Jan 16 '15 at 15:12
  • So you have 1 view per taxonomy-genre/taxonomy-platform? Are they built through the Views UI or in code?
    – Djouuuuh
    Jan 16 '15 at 15:14
  • Built on Views. I tried using Taxonomy Views to link the default taxonomy page to a view, so there are aliased URLs for the first parameter already: misite.com/strategy/[parameter] But this [parameter] doesn't reach the view, Drupal just gives me a 404. Jan 16 '15 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.