1

I am new to Drupal and partly taking it up because I want to use it as a front-end for MySQL when I move from Windows to Linux (instead of MS Access).

I'm getting the impression there isn't much interest in people who use Drupal in Windows (e.g. my current OS Windows 7) with Apache.

Does anyone know if it is actually possible to get Clean_URLs working with W7 + Apache? NB I have enabled mod_rewrite in httpd.conf.

later

Perhaps you won't be surprised to know that I'm looking for the long answer, not just "yes" :-)

Having enabled mod_rewrite, I restarted Apache, went back to my site and went Config --> Clean URLs. I still get "Clean URLs cannot be enabled"

later

Before this gets squashed as a dupe, in the referenced answer it is not clear to me where "AccessFileName" goes in httpd.conf. Also I have put one of 3 instances of "AllowOverride"s in httpd.conf to "All" (inside the <Directory /> section). I have also

1) tried putting the AccessFileName directive inside this <Directory /> section: result: Apache won't restart
2) tried setting the other 2 "AllowOverride"s in the file to "None": result: Apache restarted but trying to locate to the site reported an error

NB I've also tried putting the AccessFileName at the end of the file... still get "The clean URL test failed". I think ".htaccess" is almost certainly the default filename anyway

NB2 This is not WAMPP: I have individually configured Apache, PHP and MySQL to work together. So there's no WAMPP console as such.

later still I really don't think just referring to that other answer will provide a solution.

Following the instructions at Drupal page https://www.drupal.org/getting-started/clean-urls#general, I have reason to believe that my .htaccess file is being ignored (not read by Apache).

Secondly, of the three cases of "AllowOverride" in httpd.conf, only one can be changed to "All" without my getting a "Server error" after I restart Apache and try to point the browser at the page.

I confess I just don't know enough about Apache (or Drupal) to understand how to get Apache (not in a WAMPP stack!) to modify .htaccess as it appears to need to.

closed as too broad by Елин Й., Mołot, Krishna Mohan, Bala, Beebee Feb 13 '15 at 0:46

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • possible duplicate of Cannot enable clean URLs – Елин Й. Jan 17 '15 at 17:25
  • Perhaps just try either XAMPP (recommended I use it myself), or Wampserver? I never had clean url issues with them. Also, are you running your website from a sub-directory? like localhost/websitename ? Then you need to edit your .htaccess file and uncomment # RewriteBase /drupal and change drupal to your websitename. Clean url test begins with $GLOBALS['base_url'] . '/admin/config/search/clean-urls/check' if that page gives 200 code then test passes. – Beebee Feb 13 '15 at 0:45
2

Clean URLs requires Apache's mod_rewrite module to be enabled.

So, the short answer is yes, it is possible.

Look at this answer: https://drupal.stackexchange.com/a/54570/10176

  • thanks... but it isn't working (pls see edit) – mike rodent Jan 17 '15 at 17:02
  • @mikerodent I've updated my answer. – Елин Й. Jan 17 '15 at 17:22
  • thanks again... before this is dismissed as a dupe, I can just say it is not currently clear to me where in httpd.conf I have to put the AccessFileName directive... – mike rodent Jan 17 '15 at 17:32
  • @mikerodent just under the AllowOverride All directive. – Елин Й. Jan 17 '15 at 17:41
  • @mikerodent look at this answer for the same question: drupal.stackexchange.com/a/54607/10176 it has a bit more information. – Елин Й. Jan 17 '15 at 17:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.