0

Rules is acting weird all of a sudden. (v. 1.28)

It seems to be reacting on an Event that has not happened.

Using Commerce. Debug log shows that Rules reacts on the "Calculating the sell price of a product" event six times when I add a product to the cart, then reacts on "After adding a product to the cart", then reacts again on "Calculating the price", then reacts on "Select available payment methods for an order."

This last one seems really weird. We haven't even entered checkout. Why react on an event that definitely has not happened?

To make matters worse the Rules under the different events are firing multiple times, so I have customers receiving multiple emails and so on.

I have rebuilt the Rules cache. I have disabled Rules Conditional. I cannot understand why this is happening. Help, please?

Rules log

2 Answers 2

1

Have a read of https://www.drupal.org/node/2403851 .

In short, Rules 2.8 is causing issues with Commerce. The module maintainers are aware and looking at the problem but until it is sorted they are suggesting rolling back to Rules 2.7.

1
  • Thanks. I read that thread yesterday but it was very specific to Pricing Rules (which I don't have) and didn't contain the link to the issue for the "mother" bug in Rules (now does). Jan 20, 2015 at 15:05
0

Rules 2.8 has a bug causing Reaction Rules to be run too early: https://www.drupal.org/node/2324587

This bug was marked fixed by the Rules people but it appears to be the cause of the problems with Rules in Commerce using Rules 2.8. One of the Commerce maintainers reopened the Rules issue on 1/16/15. It's not fixed yet.

Rules 2.8 should not be used with Commerce. It will trigger Rules before their time and break your site.

Users of Commerce with Rules 2.8 should downgrade to Rules 2.7 immediately.

2
  • However: Downgrading to Rules 1.27 has not fixed the problem apparently caused by having upgraded to 1.28.The event "Select available payment methods" is still getting reacted to when adding a product to the cart. I have cleared the Rules Cache, nothing seems to help , argh. Jan 20, 2015 at 16:40
  • Edit: I had a concurrent problem. The downgrade to Rules 2.7 did fix the problem. Feb 6, 2015 at 13:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.