The specified file temporary://fileDTbhYD could not be copied, because the destination directory is not properly configured. This may be caused by a problem with file or directory permissions. More information is available in the system log.

I have set read and write permissions for sites/default/files/ folders. I am getting permission error for profile/site/theme/themename/assets/css folder in error log. I have set the permission for this as well. Can't get through the error. Any solution??

  • 1
    The solution (and I'm not being sarcastic) is to set proper permissions on folders that need to be written to. Beyond that it's almost impossible to tell you what's wrong with your setup from here, one would need access to the command line on your machine
    – Clive
    Commented Jan 20, 2015 at 11:07
  • Thanks Clive for immediate response. I have 777 permission set for sites/default/files folders. I recently changed the server and since then i am getting this error. As i have enabled caching and compression, I supposed that the only write permission will be needed to given directory. But that is not working Commented Jan 20, 2015 at 11:15
  • Read the path in the error message carefully: profile/site/theme/themename/assets/css. You have something that's trying to write outside of sites/default/files; that's where you need to make the permissions change
    – Clive
    Commented Jan 20, 2015 at 11:23
  • Thanks Clive. I set 777 for profile/site/theme/themename/assets/css folders and i think the error has gone. Thanks for help. Commented Jan 20, 2015 at 11:43
  • Hi Clive The error i was getting got resolved. Site was working perfectly after this. Since yesterday night I am getting following error in error logs. File temporary://fileBg9w7l could not be copied, because the destination directory public://css is not configured correctly. Also in front end the css is effected and site is not looking proper. To have previous issue resolved i had also asked the server Commented Jan 21, 2015 at 7:47

1 Answer 1


For those landing here from a web search, I ran into this exact problem when setting up a test server (in my case for backdrop cms, a fork of Drupal).

What it required on my end was to edit /etc/php-fpm.d/www.conf to change the entries for:

 user = your-webserver-user
 group = your-webserver-group

add then add the user to the list

listen.acl_users = apache,nginx,your-webserver-user

then running

systemctl restart php-fpm

You can get your webserver user by checking /etc/httpd/conf/httpd.conf

User your-webserver-user
Group your-webserver-group

Hope that is useful to someone else out there. No amount of chmod/chown fixed it for me, this is what did.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.