2

I created a view with articles. All I need is to trim titles.
The reason I cannot do this from content types (teaser view) is because the title field is a node module element. (It cannot be deleted, and is too late for that.)

There is an option in views output in the preview mode/contextual menus/rewrite results, but it seems it won't work.

screenshot

None of the rewrite results options will work. It looks like a bug in the Views module.

  • Try to increase the maximum length, then it will work – inizio Jul 12 '13 at 6:26
2

Clear your Drupal cache by visiting /admin/config/development/performance or if you use the Drush module, simply run drush cc all

Also make sure you're editing and viewing the correct view. If you're modify the master display but viewing an overwritten display, your master view settings will have no effect.

| improve this answer | |
0

I was able to successfully trim node titles to 5 characters using the controls you show above.The following view normally produces 'SR 1-1, SR 1-2, SR 1-3'. With trimming enabled I get:

Node titles trimmed to 5 characters

I used versions: drupal-7.9, ctools-7.x-1.0-rc1, views-7.x-3.0-rc1. Perhaps you need to upgrade your views or ctools modules. When you upgrade any module, always be sure to run update.php.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.