1

I've seen other questions related to this require_once error but none seemed to have cleared the issue for me. I'm getting the error

Fatal error: require_once(): Failed opening required '/var/www/html/sites/default/files/css/css_ameo32TxJT0SmdjsT3Q3NttK5wvcUqA.css.gz' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/html/includes/bootstrap.inc on line 3179.

The gzipped file doesn't exist, and when I've tried to simply rename other files to fix the error I've had no luck. Any help would be appreciated. Also here is the code including line 3179 - require_once DRUPAL_ROOT . '/' . $file;

 if ($file) {
require_once DRUPAL_ROOT . '/' . $file;
return TRUE;
  }
  else {
    return FALSE;
  }
}
  • How does a css or .gz file end up being required? Stack trace to see where this file originates from. And even if it were to find that file, it will result in an error as it is not php script. – J. Reynolds Jan 23 '15 at 4:52
  • @J.Reynolds thanks, I agree, seems like a funky type of error, a css or .gz file shouldn't break a site, just break the display. . investigating. . .could this be a memory issue dealing with pear or php? – A. Evans Jan 23 '15 at 5:11
  • Do you get this with CSS aggregation turned off and after a cache clear? – burnsjeremy Jan 23 '15 at 6:51
  • @burnsjeremy I can't log in, so I'm unable turn off CSS Aggregation. I'm emptied all cache tables via phpMyadmin and I still have the error. Is there a way to turn off CSS aggregration via a table in phpMyAdmin? Thanks – A. Evans Jan 23 '15 at 14:48
  • Not sure where the setting is in the DB but you can turn it off in your settings file by adding $conf['preprocess_css'] = FALSE; //optimize css $conf['preprocess_js'] = FALSE; //optimize javascript – burnsjeremy Jan 23 '15 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.