0

I had my site for quite some time and just started to use the display suite view modes feature for changing the displays per node. I made new view modes and tried to change them for my nodes, but it seems that its just stuck on "default" view mode which is the full content view. I currently on display suite 7.1.x and updated to the latest as of Jan-2015 and it still does the same thing. Any hints would be great.

0

This seems to be an ongoing issue as there are reports of other modules conflicting with the display suite view modes feature. For some it had to do with Panels as seen here:

https://www.drupal.org/node/1919452

Posted by drupalstrap on February 17, 2013 at 5:57am Greetings,

The only view mode i am able to use is the default view mode. As long as I am using the default view mode, I can switch layouts without any problem. If I try to switch to another view mode, it still uses the settings of the default view mode. I have tried every way of troubleshooting that I can think of including changing themes, altering CSS files and tpl.php files etc in order to try to isolate the problem. Furthermore, i am not able to apply wrapper or class styles via the UI settings. They don't appear in the source code.

Anyway, I have been battling this for two days now and figured I would see if anybody out there has any suggestions. On the server side, I am using php 5.3 with apc. I have tried clearing cache hundreds of times as well as restarting the server to see if there was something in memory that was stuck. I have also tried other browsers so it is something related to my development environment I guess. LAMP??? Please help. Thanks.

Upload new files Comments billsdesk’s picture Comment #1billsdesk commented 2 years ago I am having the same problem. I created a view mode and set it as the view mode to use when I edited the page. Yet, the Full Content mode is always used, and not the specified view mode. The Manage Display tab always opens the correct view mode. I turned on the view mode switcher, and it correctly identifies that the page opened in the full content mode. However, it does allow switching to the correct mode. I checked the permissions, and all is good. No error messages. I am using Drupal 7.22, and Display Suite 7-2.3. report spam on user billsdesk alunyov’s picture Comment #2alunyov commented about a year ago Hello, I had same problem. In my case switching off panel for node view helped to solve the issue. I think it is something related with page manager. If you check settings page: admin/structure/ds/list/extras -> Other -> "View mode per node" option, in description you will find "Change view modes for individual nodes. A new tab 'Display settings' will appear on the content create form. You can also pass the name of a view mode through the URL, eg node/x?v=full. If you install the Page manager module and override the node view, Page manager will win."

Added: check _ds_extras_menu_alter() in ds_extras.registry.inc. it explains a lot report spam on user alunyov aspilicious’s picture Comment #3aspilicious commented about a year ago Status: Active » Closed (works as designed) Closing this works as designed. If you still have this issue and you DON'T have page manager enabled please reopen this one. report spam on user aspilicious Geijutsuka’s picture Comment #4Geijutsuka commented about a year ago I'm having this problem on a new site I've been developing... The strange thing is that it's only happened within the last couple weeks. Something triggered this behavior, but I'm not sure what yet (trying to figure out STR).

I set up a brand-new sandbox site with everything up-to-date and it seems to work as designed... flawless. I also don't have Page Manager or Panels installed, and I definitely don't want to have to resort to changing the view mode for every single piece of content. I'm going to update the problematic site (ds is up to date, but there are a lot of other updates) and see if that fixes it... if not, I'll be back.

In my case it wasn't panels that was causing the issue but it was due to the "revisioning" module that cause the view mode to get stuck on default. There has also been reports here:

https://www.drupal.org/node/2304917#comment-9550067

I updated to the latest revisioning v7.1.9 and it still causes issues with the view mode. The only option is to turn this off if revisioning is really not necessary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.