0

Presently I am using the Windows Server on which the drupal 7.34 is installed with the xampp server.

The url for the site is localhost:8081/example

When I enter the URL(localohost:8081/example) to login, the page simply re-directs to the login page

Page re-directs showing the login block at the left of the page even after a successful login

Whereas when I enter the complete URL (the IP address along with the port number it loads the site)

Entered the complete IP Address along with the port no then the page loads with ease

Now I can't figure out why the page is redirecting me to the login page but not the main page when I am entering the localhost:portno/example

[update]On entering the URL from my system it gives that the following IP address is banned.

Things Tried:-

1.Pinged the IP address and it was successful with no loss.

2.Tried it on a different browser Internet explorer got Error HTTP Error 403 Forbidden.

3.Tried on a different system with the same IP address and in that system the site loads fine.

  1. Re-installed the drupal software again with the same localhost:portno/
0

This behavior is normal

The default front page of Drupal is this one. It displays the latest published and promoted nodes. If you want to put another node as a front page you can do it in configuration>site information

Also drupal assumes that your site is in the top level directory (e.g. yourserver:port/) If you want to change it to yourserver:port/custompath/ then set the $base_url to custompath in your settings.php file

  • say The regular url is localhost:8080/example shall load the default page(image 1 with the left block as login,password),then even the 192.168.21.11:8080/example which I enter in the server should also load the same default page(image 1) then why the difference?(the ip address which is the same example should also load the image 1 but not image 2).I have checked the settings.php fileand the $base_url = 'example.com'; is the same for default settings as well as settings – user285oo6 Jan 27 '15 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.