0

I have been having problems with facebook integration, and I know there are lots of other posts about this as I've been looking through lots of them. I see plenty of information about FB picking the wrong image, but in my case, the image is correct, and the preview of what is going to be posted from ShareThis is perfect. Even the facebook debugger tool has it all correct, but when I actually post it to facebook, the image is just empty.

What confuses me even more is that 2 of my other content types work, and the third doesn't. All 3 are defined in the same fashion, using the metatags open graph module to define the tokens for the meta data. In each page, the source is the same, and the og:image tag is always correct. When copying the image URL out of the source and browsing, the image loads perfectly.

I swear sometimes that facebook just does whatever it feels like sometimes. Anybody have any advice on why 2 of 3 content types work fine, but the 3rd never works?

I have looked at the settings for each imagefield, and they are all nearly identical. None of them are being stored in specific folders, they are all publicly accessible. As an example, the URL http://natureupnorth.org/encounter/mark-martin/smaller-haystack gives me no problems in the facebook debugger, previews fine, but results in just an outline of an image on facebook.

Any help greatly appreciated.

0

http://natureupnorth.org/sites/default/files/styles/encounter_big_image/public?itok=5aqi4xn6

That og:image gives me a 403 error. Is this set to require a logged in user?

  • Yes, sorry, you do have to be logged in. – Brian Williams Jan 28 '15 at 22:10
  • @BrianWilliams well there's your problem ;) Facebook can't read that. – user5482 Jan 28 '15 at 22:11
  • Actually its giving me the same access denied, and I am logged in. I had just tried creating a new imagecache preset, but i know i was testing the direct image urls and they are accessible previously – Brian Williams Jan 28 '15 at 22:13
  • Yeah just hte link you posted is missing the actual image name, it works fine anonymously – Brian Williams Jan 28 '15 at 22:15
  • You should be able to get to natureupnorth.org/sites/default/files/styles/large_square/… – Brian Williams Jan 28 '15 at 22:15
0

Check the permission for non logged users see this image, cause facebook engine will not log in your site to get this image.

  • If you had read the comments in the previous answer you'd see that permissions are set for anyone to view the images. – Brian Williams Jan 30 '15 at 0:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.