0

I use Drupal 7.34, and Panels module suit version 3.4.7.

The Panels in-place editor shortcut refuses to show up after I click on the gear wheel of a Mini-Panel...

  1. Tried to reinstall, didn't help.
  2. Tried to change Render mode from Default to "In-place editor" in the settings page. Didn't help.
  3. Tried to clear cache afterwards. Didn't help.
  4. No serious solution appeared in a Google search...

Is it bug?... What else can cause it not to appear?

1

Tried to reproduce this with Drupal 7.34 and Panels 7.x-3.4. I created a page, selected In-Place editor for Renderer under General tab of the Panels edit page, added some blocks and added a Mini panel with blocks in it, went to the page and all the gear icons work. Maybe some JS issue is causing this?

Update

Based on checks, I think Contextual links displays the edit link for the "renderer" only. Ex. if Blocks is displaying the Mini-panel, the contextual link module displays the "Configure block" link. Same for Panels with mini-panels rendered inside it. So that's the explanation why the "Edit mini-panel" link isn't displayed under the "gear" icon.

NOTE: Please correct me if I'm wrong with this analogy though because this is just based on observation

Solution 1: Using the Custom Contextual Links. Though this uses Tokens it doesn't get the mini-panel's name so if you had 10 mini-panels you should create 10 CCLs also w/c would be quite tedious though but of course if it's needed, nothing is tedious I guess? :)

Solution 2: Creating a custom module that would check each rendered "block" in a page is a mini-panel and if it is, display both the "renderer's" link and add the mini-panels link.

  • Oh man, I really hope it's not a JS issue because I don't have any knowledge in this field... Is there any set of settings you might want to take a look at?, I could make a screenshot of everything in the system. – JohnDoea Feb 2 '15 at 4:35
  • Im also using CTools 7.x-1.4. How about the version you're using? Also is Status Report (admin/reports/status) all good? how about Drupal logs? – Leolando Tan Feb 2 '15 at 5:43
  • I use CTools 1.5.7. I've now checked the Status report and Ironically only 2 modules require update, these are Panels and CTools... I'll try to update them and see what happens (and report here). About Drupal Logs, which one of them do you mean?, I have seen 3 log modules: Database logging, Statistics, and Syslog, and I need to know which one of them is relevant and what should I try to extract from it (in practics, only Database logging was checked in so I'm afraid the other two won't be of help in this case). – JohnDoea Feb 2 '15 at 6:31
  • Well, I'm sorry to say that even that I've updated both modules (and ran Cron and cleared cache afterwards), the problem persists... If the database logging module couldn't supply any clue, It might really be a Jquery bug. Any code you might want to take a look at? – JohnDoea Feb 2 '15 at 6:39
  • Oh sorry! Alright. I think we need too look for some JS issues or maybe PHP errors on the DB Log (admin/reports/dblog). By the way, have you tried a fresh Drupal installation? Did Panels IPE work? Can you also check the browser developer tool if there are some JS errors please. Code to look at? Well, do you have JQuery Update module installed? – Leolando Tan Feb 2 '15 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.