0

I have a Drupal 6 site and I want to add a block to a page. This block is generated from a custom module, from the hook_block function.

Under the blocks admin section, under Page specific visibility settings header, there is the setting for Show block on specific pages. I've entered my url under Pages and selected Show on only the listed pages.

When I click save, Drupal wraps my path in <p> tags. I don't have anything in my module that would be overriding the default drupal behavior. Why is this happening and how can I get it to stop?

1

We have CK Editor enabled on our site. In order to fix this, I had to go under CK Editor and change the profile for my role. Under Visibility Settings, there was a place to specify paths of textareas not to affect. I put in the path and I'm good to go!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.