3

Currently, SpamSpan seems to work well for anything outside of Views. Having a hard time finding a solution for e-mails that are displayed through the Views module.

Any help would be very much appreciated.

1

SpamSpan can do that for views too. You need to select te SpamSpan formatter on your display settings of the field.

Screenshot of e-mail formatter in views

8
  • Ok, so I go to Structure >> Views >> "View name" >> Displays >> Fields >> E-mail field. I don't see any options for SpamSpan formatter. Am I in the wrong settings area? – em en design Feb 3 '15 at 16:37
  • I've added a screenshot. Just under 'Exclude from display' you can see 'Formatter'. – Maarten De Block Feb 4 '15 at 7:30
  • Thank you for this. I don't actually have that option available under the 'Exclude from Display'. Here is what I am seeing. i.imgur.com/dgGS6Ry.png – em en design Feb 4 '15 at 14:41
  • The module is enabled and appears to be working otherwise. – em en design Feb 4 '15 at 14:44
  • Are you using drupal.org/project/email for the field? Or is it plain text? – Maarten De Block Feb 4 '15 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.