0

As it stands I have no content going to the front page, i am simply using a template file for the front. When I sign out and sign in as any role of user on my site my front page url turns into: www.mysite.com/node

I do not want this behavior, and have tried several methods but nothing seems to work.

I have tried adding this snippet to setting.php:

function custom_url_rewrite_inbound(&$result, $path, $path_language) { if ($path == 'node') { $result = ''; } }

I have tried creating a custom module and have tried every suggestion from https://www.drupal.org/node/500296 nothing works.

I have encountered this behavior before, and to solve the issue i added the Node Page Disable module and deselected the Retain /node as an active url? checkbox which removed the /node from the home page URL.

Now when I implement the module and deselect the checkbox and save the form, the checkbox goes back to being selected after the form is submitted. I cannot figure out what is going on, I have cleared every cache known to man-kind, used different machines and operating systems so obviously something is conflicting. I just don't know where to look.

I cannot post a bug/issue to the module page because drupal site is currently broken for creating new users... This is a nightmare. If anyone could give me some insight on possible conflicts or have any crazy ideas how I could get around removing this useless /node from the home page after a user signs in; it would mean the world to me. Thanks regardless.

1

I used Global Redirect and it seems to do the trick. I'll still accept someone else's answer if anyone can give any insight on what might of been the solution to my original issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.