I am trying to add a rule for comment view for which under the actions I click on data compare.As per the tutorial, I have to click the drop down list and choose node. Data selector with options in the drop down like site,site...,node,view

Whereas when I repeat the exact same steps from the Conditions->data compare I got some lesser menu option :

the data selector has only 4 options site,site..,comment,comment..

Now my problem is that as I don't have the node option to choose how am I supposed to complete the tutorial.

This kind of missing options appear quite frequently (when I tried to add an action/replacement patterns/ I had to choose the node type whereas in the options list there was no [node:type]. Again after 24 hours when I re-try this I get the [node:type])

I don't get the reason which is causing this problem. After doing the troubleshooting steps like re-login, clear browser cache, flush cache the options list is still the same.

1 Answer 1


As a temporary way around I have done the reinstall of 7.34 and installed all the modules from the start.This got me back the menu but I cannot do the un-install every time this problem comes. I will be losing a lot of time

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.