0

How can I disable ajax in admin/commerce/products (Commerce Kickstart 2 menu)? I've searched in Search API settings but found nothing.

Edit: I found that the View Commerce Backoffice: Products (Content) control the search of products in admin/commerce/products. In section Advanced > OTHER there is field Use AJAX. You can set to Yes or No this field. But even if you set to No, when you search for a product the query is made before you press Enter, what is exactly my client want.

So the question persists, is there a way to change this behavior, to be able to search only when you press Enter?

  • It's a View isn't it? Try disabling AJAX in the View edit form? – Clive Feb 5 '15 at 14:47
  • Thanks @Clive. I disabled AJAX in Advanced/OTHER/Use Ajax option in the View. Now when searching, the animated blue clock doesn't appear but the page keep refresh as I insert some letters in the text box. Is there other option to be changed? – Caco Feb 5 '15 at 17:28
1

You can install (if it's not installed yet) Better Exposed Filters. If you edit the View in admin/commerce/products/list (or any of them) and you select BEF for displaying your exposed filters (using defaults) then the autosubmit feature will no longer work.

On the other hand, see https://www.drupal.org/node/1735254 for an explanation on how to disable the autosubmit feature. It's just adding a CSS class to your filter. You have to find out how to add classes to exposed filters in Views, though. Some dirty jQuery can help, I guess.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.