0

I recently migrated a site from a Drupal 6 install to a fresh Drupal 7 install.

I then installed panels 7.x-3.5. Initially I had an older version of ctools installed, so I had to upgrade from 7.x-1.4 to ctools 7.x-1.6.

I then enabled panels the panels page is not showing up in "Structure". I checked permissions and all the correct permissions have been added.

I then try to flush my cache, and i get this error:

Fatal error: Class 'panels_renderer_standard' not found in C:\wamp\www\projects\elaw\sites\all\modules\panels\plugins\display_renderers\panels_renderer_editor.class.php on line 8

Here is a picture of the error with a full stack trace:

enter image description here

I can run cron just fine, but trying to clear the cache gives that error. In the modules page "Panels" is enabled.

enter image description here

Before upgrading ctools, I had saved a files/database copy and then tried removing panels from "modules" and adding Panels 3.4 instead. I got the same error.
I then restored my files and database and tried it again but with upgrading ctools instead as mentioned above.

There was also this error that briefly flashed up when I was enabling the module from the "modules" page, after the ctools upgrade.

enter image description here

********UPDATE*********

I was able to get the cache to clear by just hitting reload. But, if after the cache clears I try to clear the cache I get the same error. Now the "panels" shows up in Management->Structure, but it has a strange error on the top of the page:

Notice: Undefined index: rows in page_manager_panels_dashboard_blocks() (line 1251 of C:\wamp\www\projects\elaw\sites\all\modules\ctools\page_manager\page_manager.module).
Warning: Invalid argument supplied for foreach() in page_manager_panels_dashboard_blocks() (line 1251 of C:\wamp\www\projects\elaw\sites\all\modules\ctools\page_manager\page_manager.module).

enter image description here

Notice how none of the predefined panel pages are showing up?

I hit clear cache a couple more times (with it giving the "class panels_renderer_standard not found bug each time I cleared the cache initially and it clearing after I hit reload), and now the panels page is showing the Predefined Panel Pages, (user page, etc):

enter image description here

I tried creating a new panel page and got this bug:

enter image description here

I can't seem to create a new panel page.

****END UPDATE*****

************************S E C O N D U P D A T E*****************

I had an idea that perhaps it was a contributed module that was causing the error. I was going to just randomly start disabling contributed modules but I thought I would start with any contributed module that had ANYTHING to do with panels. I found that disabling "Panels Translation" in the "Internationalization" section fixes the problem. enter image description here

I'm not sure why this was causing the problem, but after disabling it I no longer get the " Fatal error: Class 'panels_renderer_standard' not found" error. I am also able to get further in creating new panel pages. I get all the way up to saving and it gives this error:

enter image description here

I have verified that that table is not in the database....

I am on a very tight deadline and would appreciate anyone's insight. Thanks very much for any help.

Sincerely,

David

  • Did you run update.php when you upgraded the ctools module? – Darvanen Feb 11 '15 at 23:54
  • Yes I did run update and there were no errors. I added a picture of another call stack that showed up during the enabling of Panels from the modules page. – David Pugh Feb 11 '15 at 23:56
0

Check your modules/panels/plugins/display_renderers folder and make sure there is a file named panels_renderer_standard.class.php inside, that's where the class is contained that is supposedly missing.

Try completely replacing the panels module code with a fresh download, that is: move the current module folder somewhere else (so you can get it again if you need to) and re-upload the module.

If you're applying any patches, make sure you check them for code that might be deleting, renaming, or disabling the display_renderer_standard class.

  • Hello, I checked, and panels_renderer_standard.class.php is in that folder. – David Pugh Feb 12 '15 at 1:59
  • Even so, try replacing the module code. – Darvanen Feb 12 '15 at 1:59
  • I removed the panels module code, and downloaded a fresh copy. I installed it in the "modules" folder and it has the same problems. I am not applying any patches. – David Pugh Feb 12 '15 at 2:02
  • Then I'm out of ideas, sorry. – Darvanen Feb 12 '15 at 3:03
  • I got a bit further by disabling Panels Translation. Now I'm getting a Base table or view not found: 1146 Table 'newelaw.page_manager_pages' doesn't exist error when creating a new page. – David Pugh Feb 12 '15 at 3:38
0

The problem was that I originally was trying to install panels 7.x-3.5, which required ctools 7.x-1.6. I only had ctools 1.4 installed, so on the modules page the enabling of the panels module was disabled with a warning that ctools > 1.5 was needed.

There is a bug if you try to install panels 3.5 and don't have the proper ctools version installed. It for some reason won't install the tables for Panels when you enable the panels module, even if you get the proper ctools version or downgrade your panels to a lower version of panels that does not require a ctools upgrade.

Panels was literally refusing to install any tables.

Clearing the cache via the user interface was not enough.

My solution was to start with my project that had ctools 1.4 installed and panels 3.5. Remove Panels 3.5 module from the modules folder, and I truncated every single table in the database that started with cache_... as well as the cache table. I then installed Panels 3.4 and enabled it, and the database tables for Panels were then installed properly. I can see the template pages in the "Pages" section for Panels and create new Panels with no errors.

You probably don't need to truncate all of the cache_ tables, but I wasn't sure which ones to try, so I decided on trying all of them as this bug turned into a major headache.

I know at least one other person has had this problem (looking at the Panels module bug section) so I hope this helps someone.

Sincerely,

David

  • If this doesn't work for someone then another possible answer posted by @Letharion might be: "Find a list of tables the module creates in the .install file. Manually drop the tables, set the module status to 0 in the system table. Install the module again. Now try un-installing, (just in case the module wants to do extra cleanup, beyond tables), and finally install." Thanks, Letharion. – David Pugh Feb 15 '15 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.