1

I have a slideshow block that does a slideshow for a news stories that take two images. An image for the page and a teaser image for the slideshow. but the image never shows up in the slideshow. The image url is sites/default/files/styles/mt_slideshow/public but the actual location of the image after its uploaded is sites/default/files. so is there a way to force the image to be uploded where this site is looking, or change where the site looks to where the image is uploaded?

  • It sounds like your image style files might not be generating. The original file is in /sites/default/files but your slideshow is using an image style 'mt_slideshow' which is generated by Drupal and placed in 'sites/default/files/styles/mt_slideshow/public' -- check your error log to see if there's anything related to this (/admin/reports/dblog). It could be a permissions issue or something else. You might also make sure that image style exists. – thumbson Feb 12 '15 at 18:14
0

In your site log in as adminstrator and go to

'/admin/config/media/file-system' 

and you can find the place where you can define your path to save any uploaded files.

for Example your siteis example.com you have to access

"**example.com//admin/config/media/file-system**" as Drupal Administrator and you can change the path there.

image URLs messing up

possibly this will give you a answer

  • i did that. i have set it to save files in sites/default files but the url is still example.com/sites/default/files/styles/mt_slideshow/public/Penguins_1.jpg?itok=xALPiy4m – bbell0971 Feb 12 '15 at 18:10
  • are you using image field for the images? if yes go to that field setting in your content type and check "File directory " if there is any directory name called "styles/mt_slideshow/public" in that field remove that and check – DEVARAJ JOHNSON Feb 12 '15 at 18:19
  • Yes its an image field. the file directory box is blank. i havent put anything in there – bbell0971 Feb 12 '15 at 18:41
  • check this link drupal.stackexchange.com/questions/26311/… i believe it helps – DEVARAJ JOHNSON Feb 12 '15 at 18:45
  • If I am reading that correctly it says this is a permission issue? if i just chmod 777 to all of the directories in the file path it should fix my problem? – bbell0971 Feb 12 '15 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.