This question already has an answer here:

All of a sudden when I insert a picture into a page, it shows an edit and a delete button above the image to the end user. These buttons take you to the default page. Also, now when I edit a page from the edit button at the top of each page and save, I get the following type of message after a lengthy wait.

Fatal error: Allowed memory size of 356515840 bytes exhausted (tried to allocate 523800 bytes) in /data/www/luna/sites/all/modules/token/token.module on line 767

I can edit and save if I select the page under Content.

See http://lunahq.com/content/luna-rox-v8-simple-smarter

marked as duplicate by kenorb, Adrian Cid Almaguer, Shawn Conn, Scott Joudry, No Sssweat Mar 12 '16 at 1:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Thx but I don't think that will get rid of the Edit and Delete buttons? I'm pretty sure the image and the memory problem are related. – Newbie Feb 21 '15 at 17:46

you need to increase the memory limit size in php.ini

That indicates that Drupal needed more memory than PHP was allowed to give it.

Drupal 7

Memory increase to 128M:
(This has worked every-time; and used to always work for D6 as well)

Create a new file php.ini, and add the code...
php_value memory_limit = "128M"
and put that file in your Drupal 7 (or D6) root folder.
    For step-by-step details, see comment below...
    Drupal 7 "Fatal error: Allowed memory size of ...".
If you need more than 128M:

Add the line
ini_set('memory_limit', '512M');
to your [Drupal 7 root]/sites/default/settings.php file.

I have yet to need this much memory, but I did achieve
a memory increase to 512M using this slightly more complicated
process that involved temporarily changing the permission level
for that file.
    For step-by-step details see the comment below Drupal 7 memory increase to more than 128M.

refer this link


Not the answer you're looking for? Browse other questions tagged or ask your own question.