3

I have a block I want displayed on a view page, which has filtering and pagination. The block shows fine when you change the filter, but if you go to page 2 (or any other page than the first), the block disappears. In the block config I have the following under "Only the listed pages":

myview
myview/*

How do I make it appear on all the pages in the view?

0

2 Answers 2

7

It turns out since my block was itself a view, it received the page param from the url, and since pagination was turned on, it just went to other pages, which happened to be empty.

I fixed it by turning off pagination on the block view.

2
  • Your solution worked for me, several years later. Now that time has passed I hope you can mark this as solved.
    – Screenack
    Commented Jul 14, 2013 at 23:29
  • To turn off pagination for blocks, it seems you have to set it to "Display All Items" Commented Jul 3, 2019 at 0:17
1

use myview*

the pager will call change the URI to

myview?page=2 ...

myview* will cover that case

1
  • Actually myview* wasn't needed, check my own answer to see what I was doing wrong.. :)
    – cambraca
    Commented Nov 8, 2011 at 2:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.