1

When I upload and image in the WYSIWYG, the image is added to the /sites/default/files/ folder, but cannot be seen on the web becasue IIS_IUSRS does not have the correct file permissions. Also, the permissions are only viewable by an administrator.

I tried the answer given on IMCE image upload and permissions issue, but both the temp and destination folders give IIS_IUSRS and IUSRS read/write/modify. I have even tried temporarily giveing 'Everyone' full control to get this working, but that does not help.

I have to click Advanced to view file permissions (I am logged in as an administrator)

First, I have to click advanced to view the uploaded files permissions. I don't have to do that on the folders or other files in the folder.

Then I have to give Administrator permission. Again, this is not required on the folders or other files in the folder. Give Admin Permission

Then I can see the file permissions and IIS_IUSRS has List folder/read data, not modify. Also, this is inherited from 'Parent Object' not the parent folder. Permissions

If I click Disable inheritence and remove all permissions, then click enable inheritrance and apply, the correct permissions re inherited and the image can be seen on the web. Permissions after disabling then enabling inheritence

Has anyone else experienced this? Why doesn't the uploaded file inherit the folder permissiosn correctly in the first place? Why do I have to disable then enable inheritence to get it to work?

I need to fix this because the web editors will be adding a lot of images and it is not practical for me to manually change the permissiosn every time.

I don't know if this is an error with Windows Server 2012, IIS 8.5, CKEditor or ElFinder.

I am using ElFinder, but was only able to tag this with CKfinder. I am using Plupload as well, but can't remember if it integrates with ElFidner or not.

P.S. This site is stil in development. I will remove 'Everyone' before it goes live.

1

I was able to correct this by enabling inheritance on the c:\windows\temp folder, after verifying that the IIS_IUSRS (machinename) account has read & execute/list folder contents/read permissions. I was prompted about a potential security risk, but ultimately this fixed it.

  • Sorry for the delay responding - I was away. That worked. Thanks! – traceyspencer Mar 17 '15 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.