0

Updated via drush, flexslider module v.7.x-2.0-alpha3 is installed.
Installed latest version of library 2.3.0, released 17 days ago as of the time of this writing.
Getting drupal pesky error about version not recognized, so decided to downgrade library to 2.2.2, same error. Moreover I am getting following errors in status report:

Warning: fopen(sites/all/libraries/flexslider/jquery.flexslider-min.js): failed to open stream: Permission denied in _flexslider_requirements_library_installed() (line 212 of /var/www/asflorida.com/sites/all/modules/flexslider/flexslider.install).
Warning: fread() expects parameter 1 to be resource, boolean given in _flexslider_requirements_library_installed() (line 213 of /var/www/asflorida.com/sites/all/modules/flexslider/flexslider.install).  

Before somebody tells me that this is a perm issue: I checked thoroughly and perms are 775 throughout and ownership is correct.
Either alpha 3 is not working with older library or viceversa.
Thanks in advance.

  • Just want to mention that I use alpha3 with 2.2.2 with no issues. Drupal status page should show "Version 2.2 installed". Flush your caches - manually check README.mdown in the library folder for version 2.2.2 – Patrick Ryan Feb 28 '15 at 17:23
  • well, that was my answer, the problem is that alpha3 will not recognize 2.3.0. – ckosloff Mar 1 '15 at 18:13
0

Basically this is a duplicate issue, workaround (cannot be called solution) is to downgrade from v.2.3.0 to 2.2.2.
I already posted in the module's issue queue. The other issues were caused by ownership and perms issues, while I was testing both library versions, disregard that part.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.