I'm using the 'Solr Search' module ( not Apache solr search ) .

What I need to do is return results that have a taxonomy term relationship.

In my search indexes 'fields' I have the taxonomy I want 'Keywords' selected. The type for this is 'Taxonomy term' . I have also added 'Keywords » Name' through 'Add Related Fields' . This is type 'Fulltext' and after reindexing and saving this field appears in views/search/page / search ‘full text’ / Searched fields.

However when I search for a keyword through the exposed filter the results are not being returned. They can however been seen in Facets.

Any idea what I might be missing.

  • When you said Solr Search you mean search api ? Did you re-index your content ? Usually when I'm using Search api module and I make changes I need to re-index my content in order to see the changes. Mar 2, 2015 at 20:24
  • Hi. Yeah I had been re indexing. It might have been something obvious tho as I rebuilt the search view and this worked fine.
    – Deejay
    Mar 2, 2015 at 22:08
  • Common mistakes it happen to me all the time. Mar 2, 2015 at 22:20

1 Answer 1


I rebuilt the view and this time it worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.