3

Before using Entity Translation, I used the Language switcher (User interface text) to allow the users to switch between languages on the header.

On the 'Configure entity translation' page, under the heading 'Enable a different language switcher', it states:

When the Entity translation module is installed, a second language switcher block is made available on the site called Language switcher (Content). Enabling this block rather than the default language switcher block, Language switcher (User interface text), will ensure that the language of the content is updated when the language switcher is used.

However, when I place the 'Language switcher (Content)' block in the header, it does not even show up. Switching back to 'Language switcher (user interface)' shows it again, but then it won't ensure the language of the content is updated using the languages switcher.

3

if you want to activate the Language switcher for User or for Content you have to go to:

../admin/config/regional/language

Use the second tab "Detection and selection" and activate for "Language switcher user" the first section:

  • User interface text language detection - Enabled: YES

After that, you will see the language switcher.

For your "Language switcher content" you have to activate the other section:

  • Content language detection - Enabled: YES
2

Go to Administration » Configuration » Regional and language » Languages » DETECTION AND SELECTION tab. (admin/config/regional/language/configure)

Ensure that the 'URL' option is enabled along with the 'Interface' option.

From the guide:

To ensure that the language switcher correctly updates the language of the site, the 'URL' method must also be enabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.