2

I get an access denied on the front page with a fresh install using drush. I can get to the user page fine and login as admin. I read that it might be permissions. Not sure why be default its set like this though. Any thoughts?

Update:

Let me clarify what I need to understand. So previous deployments of drupal using drush I get a fully working site with permissions set correctly. Now I am not sure what is going on wrong but when I run

drush si standard (database info)

I get a freshly installed site with no permissions on the front page. Now I guess what I am trying to understand what is causing this using drush. From what I know and experienced drush si should install the site to a state in which drupal has permissions of anonymous set correct.

I can manipulate the database after deployment but I'd rather not do that if I can make it work with drush right away.

So what could be causing this issue? Am I using drush incorrectly when deploying it?

update: I think it was a timing issue between mysql and drupal. In any case this is solved.

  • Is this a database access denied or webserver access denied? – stefgosselin Mar 6 '15 at 20:50
  • It is a "access denied" on the front page of drupal with a "You are not authorized to access this page." I get the drupal theme with it so it doesnt seem to be a apache thing. I can access mysite.com/user just fine and login then I can see the content. But as an anonymous user i get the access denied. – madmanali93 Mar 6 '15 at 20:59
  • I'd check the permissions for content to make sure the content type is accessible for anonymous users – Melissa Mar 6 '15 at 21:04
  • My scenario is that this deployment has to be automated so with drush in theory it should have been accessible but not sure why its not working. I could go into the db and manipulate the permissions but if possible id like to have install correctly to begin with. Is there a reason everytime I do a new install of this I get the access denied? – madmanali93 Mar 6 '15 at 21:10
  • I believe if you have content and your permissions are set properly in database your deployment run as expected. – stefgosselin Mar 6 '15 at 21:33
1

It may just be your content permissions are not configured.

Go in your admin, people->permissions->node and look in the "View published Content" permission, make sure anonymous and authenticated user is checked.

| improve this answer | |
  • So do you know why that happens when running a drush si standard? it almost seems like this might be a minimal install but since I haven't done a minimal install before I am not sure if this is the case. Now it works for anonymous users but it says no front page created. When I used drush before the default front page has a login and content. Do you know why in my case it differs? – madmanali93 Mar 6 '15 at 21:18
  • I don't think there is any content on a new install, though I am not 100% certain. Please accept & upvote the answer if it solved your issue so others can benefit it they encounter the same problem. Thnaks friend. – stefgosselin Mar 6 '15 at 21:24
  • This is a fix but doesn't really help me in my situation and its my fault for not writing this question properly. – madmanali93 Mar 6 '15 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.