1

One of the website that I manage the menu system is not working. I have installed many modules (including the commerce modules) and are not being displayed on the menu. However, all modules links (and commerce) works, if I type it on the URL.

After troubleshooting a little bit more I figure out that this is not only for commerce. I created a new content type and is not been display on the node/add page or in the admin_menu. And once again I'm able to go to the page if I type the URL.

I click on rebuild menu, I flush all caches and still not been register. I do not see any Drupal logs errors.

How can I address this problem ? I cannot expect the sysadmin to know all the URL.

Update 3/27/2015

I'm now using the latest Drupal (v7.35) and I noticed this at first on 7.34.

Like I mentioned before it is not only on the menu. So I do not think the admin_menu is the problem. I remove the module admin_menu and use the toolbar module. But there are missing links on the pages that are been created for the latest module that I have installed. So any module that I enable from now on it would not register the pages.

Update 4/3/2015

I'm now using the latest Drupal (v7.36) and I noticed this at first on 7.34.

I disable/uninstall and enable drupal core menu module and still not fix this issue. Someone from the Google + community suggested that this issue may be cause by the jquery updated I try to used different jQuery version and still have issues. In addition, I try to follow this How to completely wipe and rebuild drupal menus? and to rebuild all my menu and did not work.

I strongly believe is need to be something with the hook_menu not working on my Drupal website.

Update 4/4/2015

I notice that if I add a new content type it would not appear the links on the node/add nor under the content menu. However, it appear in the page admin/structure/types and in the menu under structure -- > Content Type.

Some more updates to address one of the suggested answers to try to get my issue reolved:

  • This is single site installation.
  • I do not think is because of the memory_limit. Because I have managed bigger sites that does not have this issue. I did try it out and it did not help. I.e in my setting.php I set it up to 300M and on my php.ini as well. After that I cleared caches, run cron, restart the webserver. And still nothing.
  • You should provide some information on the version of drupal you are using. Is the menu module enabled? Have you tried to disable recently added modules? Are you using git, and can you set the code base back to a prior version? Look at admin/structure/menu list-links and see that the menu items are enabled. – terry Mar 17 '15 at 21:17
  • I check the menu module is enable. By accident I enable Commerce + Ubercart and I disable and uninstall Ubercart. Unfortunately that client is not running git on their server. I when to the admin/structure/menu and they links are not even in there. – itsdarrylnorris Mar 27 '15 at 19:05
  • I have update the question. – itsdarrylnorris Mar 27 '15 at 19:22
1

It would be interesting to see if your problems could be related to the "memory limit", which might not be high enough (anymore), especially since in the OP it says "I have many modules enabled".

I'm assuming that this is NOT a multi site. So therefor consider editing your /sites/default/settings.php, and change the line to set the memory limit. If it is a multi site, then edit the settings.php file related to the site where you are experiencing the problem.

That line in settings.php should look similar to this:

ini_set('memory_limit', '100M');

The '100M' in it might be some other number. Whatever the number is, try to increase it with like 50%, or maybe even double it to see what happens after you do so (of course do not forget to save the file after increasing that number).

Curious to hear if that helps somehow ...

Here are a few other thoughts that might ring a bell in the right direction (if you haven't tried them yet):

  • temporary turn of all caching, to see what the impact is of doing so. Of course that cannot be the real solution in most cases, but at least it might give some indication like "it seems to be caching related".
  • what about compression of JavaScripts and/or CSS? If you have turned them on, what happens if you (temporary) disable them?
| improve this answer | |
  • @Pierrer.Vriens, This is single site installation. I do not think is the memory_limit due that I have manage bigger site that does not have that issue. Anyway, I try it out and did not work. On my setting.php I set it up to 300M and on my php.ini as well. After that I clear caches, run cron, restart the webserver. And still nothing. – itsdarrylnorris Apr 4 '15 at 7:54
  • I have update the question with more details. – itsdarrylnorris Apr 4 '15 at 7:55
  • Thanks for clarifying. Sometimes debugging is like "try to eliminate all possible causes, until you cannot eliminate a specific one ... which turns out to be the cause of the problem". OK? – Pierre.Vriens Apr 4 '15 at 8:04
  • Just extended my answer with 2 other possibilities that might help furhter debugging. Maybe worth exploring also? Don't think it makes sense to write them in a separated answer (at least not yet), right? Have to run now, will check later on if anything changed ... – Pierre.Vriens Apr 4 '15 at 8:21
0

The fact that items aren't showing on the node/add page is very strange and doesn't seem related to admin_menu at all. I'd suggest as a first step, to look in the menu_links table and seeing if there is an entry for the content type that's missing. in the link_path column you can see this if a node/add/ entry is there. If there is, it should also show up if you go to structure -> menu's -> navigation menu in the list.

Can you check this please?

| improve this answer | |
0

Some things to try:

  1. Are there any errors in watchdog or the server itself, especially when the cache is emptied?
  2. Can you manually empty any database tables prefixed with cache_?
  3. Is site-wide caching enabled, if so can you disable?
  4. Is there any caching mechanism installed on the server, e.g. Varnish, Memcached, APC, etc.
  5. Are you logged in as user 1 or some other user, if some other user have you checked the permissions?
| improve this answer | |
  • 1. No have do not see any watchdog or any errors logs. 2. I can manually empty the databases (using phpMyAdmin); however, I have not try it out. 3. I disable the caching to see if there was any issues and is not the caching. 4. I'm not using any caching mechanism on my server. 5. I have login as user 1 and as another administrator. And I still have the same issues. – itsdarrylnorris Apr 6 '15 at 14:09
0

I had run into this issue, fixed with these steps.

  1. Disable caching by adding this code to your settings.php

    <?php
    $conf['admin_menu_cache_client'] = FALSE;
    ?>
    
  2. Turn off php page compression and javascript aggregation at admin/config/development/
  3. Comment out the following lines in admin_menu.module file in admin_menu_js_cache function:

    header('Content-Encoding: ' . $encoding);
    $content = gzencode($content, 9, FORCE_GZIP);
    
  4. If the above doesn't work, try to change compression in PHP.ini file as

    zlib.output_compression = On replace on with Off

I remember, I got this issue when I was using Drupal 7.33. But it should work for 7.34, assuming there are no custom module. If there are any custom modules, please check if any of the .module files have misconfigured php tags.

| improve this answer | |
0

Sounds to me like one of your modules is causing a conflict in a hook_menu call and thus the menu is not being updated. To find the culprit follow standard module debugging technique:

(On a development copy):

  1. Turn off all contributed modules.
  2. Turn them on one by one until the error appears.
  3. Look for the offending code, probably in the module's hook_menu function. Check submodules and .inc files too.

An alternative is to turn modules off one by one until the error goes away, sometimes this is easier, especially if you have custom modules, you should definitely test those first.

| improve this answer | |
-1

I think this is problem with admin menu caching. Go to admin/config/administration/admin_menu Under performance vertical tab uncheck the option to cache menu in client-side browser. See if it works, otherwise try uninstalling admin_menu module completely and clearing drupal's cache and browser's cache. Also try it opening in another browser.

| improve this answer | |
  • 1
    On my first update, I mention that is not the admin_menu the problem. I have uninstall the admin_menu and reinstall and still not working. I also have use different browsers. – itsdarrylnorris Apr 4 '15 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.