2

My sites requires the use of 'Path prefix language code' under admin/config/regional/language/edit/en to append the language prefix to the URL path, so if the language is English, node/1 would become en/node/1

The problem is that when I am trying to translate content, the links to the translation pages contain this prefix too, and that will reach a page that is not there:

/tc/my-node-title/edit/zh-hant is the wrong path, the correct path is...

/my-node-title/edit/zh-hant

So is there a way to remove the language prefix on the admin panel?

0

Have you tried to use the GlobalRedirect module? You may be able to set the option 'Language Path Checking' to true in the module configuration page and add the paths for admin pages in there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.