I'm trying to send an attachment within a rule I've set up for new content notification. I have the requisite modules installed: Mail System, Mime Mail, etc. I've set the rule up to send HTML mail to users of a role, specified the body content, and the attachment in the following manner...

enter image description here

I've tried various incantations of the attachments value by changing the token. The file I'm trying to attach is an Excel file attached to an article. The email notification does get delivered, and, appears to have an icon indicating an attachment. However, when I open the email, the body text is correct, but, there's no attachment. From the research I've done, I've found that attachments seem to be an enigma. Some posts I've read imply that I need to do some coding to get this to work. Seems like I shouldn't have to. Can anyone shed some light on how to attach a file correctly?

1 Answer 1


If anyone else is struggling with this problem (and, I did find quite a few that were), I've found a work around. First, it appears like this may be a known bug. Given that, I found the work around at #25 worked for me. In my case, I had to tweak the attachments value in the rule to look like this...


Note: no preceding path was required. With the above, I now get attachments in emails that are generated via a rule.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.