4

Somehow user 1 has become blocked on a Drupal site I manage. As a result, I can't issue a uli command via Drush. I tried to use the command

drush @pantheon.xxxxxx.dev user-unblock --uid=1

but it returns error

Unknown option: --db-url.  See `drush help user-unblock` for available options.  

I have checked the help for user-unblock for but it does not mention --db-url. The site is working and and other users can log in, however I can't get in as admin.

Thanks.

3

Pantheon site aliases are only compatible with Drush 5. I had the same message when trying to use Drush 6.

On a Mac with Homebrew, I ran "brew install drush5" and then symlinked the resulting file (/usr/local/Cellar/drush5/5.9/libexec/drush) to "/usr/local/bin/drush5" not to interfere with my existing Drush installation.

Now I can run commands such as "$ drush5 @pantheon.xxx uli" when needed for Pantheon.

| improve this answer | |
  • Note for those not handy with the CLIs, symbolic link is created via "ln -s /usr/local/Cellar/drush5/5.9/libexec/drush /usr/local/bin/drush5" – areynolds May 21 '15 at 0:22
2

As of this writing, Pantheon site aliases are only compatible with Drush 5.

If you're using a newer version of Drush (6, 7, 8+), you'll likely get the following message when trying to execute a Drush command with a Pantheon alias:

$ drush @pantheon.xxx.xxx status

Unknown option: --db-url. See `drush help pm-enable` for available [error]
options. To suppress this error, add the option --strict=0.

There are two possible workarounds:

  1. Provide the option --strict=0 to each Drush command

    $ drush @pantheon.xxx.xxx status --strict=0

  2. Install Drush 5 and use it specifically with Pantheon

    If you're a Mac user and use Homebrew, the second option is as simple as:

    $ brew install drush5

    $ ln -s /usr/local/Cellar/drush5/5.9/libexec/drush /usr/local/bin/drush5

    $ drush5 @pantheon.xxx.xxx user-login

The first method works for me using Drush 8.1.9 and Drupal 7.53 (and optionally Terminus 1.0.0) on macOS 10.12.3 "Sierra". I have not personally tested the second method.

In either case, be sure your Pantheon aliases are up-to-date:

$ terminus aliases
[notice] Aliases file written to ~/.drush/pantheon.aliases.drushrc.php
| improve this answer | |
  • This is an older question, so the later answer is more applicable. --strict=0 is the quickest and least confusing solution, imo. – texas-bronius Apr 4 '17 at 10:52
1

incase someone is trying to add -- to other drush commands you can use:

terminus drush site.env -- [drush command here] -- [drush option here]

the "--" after the site.env will pass the options to drush instead of terminus.

example: terminus drush $SITE_ID -- up -s --security-only

| improve this answer | |
0

Have you tried fixing it directly in the database? You should be able to update users set status = 1 where uid = 1;

If for whatever reason you cant do this, you can try running the query with drush: drush sql-query "update users set status = 1 where uid = 1"

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.