1

I have this Drupal 7.15 site (it needs an upgrade, I know).

I have some public and private files in there (all according to my settings). I have a public file field and a private file field.

So, using my private field, I can upload some files that are set to private (I've set the allowed extensions as: .zip, .pdf, .jpg, .png, .gif, and some more). I'm the only user allowed to use the private field.

When I upload an image file (png, jpg or gif), it does get uploaded ok, but when trying to click on the link I get a "404 error". When there's any other file type uploaded, everything works just fine.

The private files field is inside a content type that is set as a "group content type".

All files get uploaded ok and they do appear at the list of uploaded files in the normal way.

Some configuration information

  • My Apache file handler is mode_php (aka DSO).
  • Permissions and file owner of all files (images or not) are the very same: rw-rw-r-- (664)
  • Group and owner are the same too (images or not): nobody and nobody
  • All files are being uploaded to the same folder: ../files/private/filename.ext
  • All files get the same symlink: ../system/files/filename.ext

But only the pdf file is accessible to users (with perms to view the node). Even as an admin I get the 404 error when trying to access the image files.

What's wrong?

  • Have you check the upload setting on your module? Like IMCE, they have permission setting per role. – CocoSkin Mar 18 '15 at 14:29
0

First, have you already checked the status report (/admin/reports/status)?

If that's all green then do you can dig around the content type field settings and also the content type view fields settings to see if you're using any image styles on the images. If you are you need to make sure the folder sites/default/files/styles has proper access perms.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.