1

I crashed my website trying to secure it by changing files and folders modifications...After i tried many things (chmod 777 -temporarly- all to take it back, clear the cache, drush rr...) nothing worked yet. So i tried to install a new site, copied all the site file...It was working perfectly.

I tried to link the new site with my old database, and the fatal error get back again...I guess my database might be corrupted...Any idea ?

Thanks for your help

(previous conversation about what i did already here

  • It might be a good idea to actually include the error you are getting. – 2pha Mar 16 '15 at 7:40
  • Sorry...It's actually alwas the same issue: fatal error from an unfound class. 'Fatal error: Call to undefined function menu_get_menus() in /home/mysite/www/sites/all/modules/xmlsitemap/xmlsitemap_menu/xmlsitemap_menu.module on line 37' – Ryan Mar 16 '15 at 8:37
  • 1
    Since xmlsitemap is not critical to your site's functionality, I say disable/uninstall then reinstall and reconfigure. Hopefully that fixes your issue. – Webdrips Mar 16 '15 at 9:13
0

As webdrips has said, your error seems to be with the xmlsitemap module, and considering it is not critical for functionality, you should try disabling it.

Depending on the state of the website, if you are experiencing WSOD, you may need to disable the module through the database using phpmyadmin.

In the system table, find the xmlsitemap module, and edit the row where the column is "status", and set that to 0.

| improve this answer | |
  • 1
    Just to add to the above, as the menu_get_menu function is part of the menu module, you might want to check the menu module is enabled in the system table. – 2pha Mar 16 '15 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.