1

I believe I have all the pieces of the Drupal RETS Real Estate Framework installed in my drupal 7 site.

https://www.drupal.org/project/drealty

But when I run:

drush -u=admin -d rets-import 

I get:

The drush command 'rets-import' could not be found.  Run `drush cache-clear drush` to clear the commandfile cache if you have installed new extensions.

What step might I have missed in my install of this framework?

  • Have you run that commnand form a directory inside your Drupal installation? Have you run the drush cache-clear drush command? Is he module enabled? – sanzante Mar 24 '15 at 14:20
  • Yes, to all 3 questions. – iewebguy Mar 24 '15 at 14:33
3

The file that integrates DRealty with Drush drealty.drush.inc is kind of in an odd place within a drush folder of the module.

http://cgit.drupalcode.org/drealty/tree/drush/drealty.drush.inc

Drush will scan the root level of a module folder or your .drush directory for drush include files but I dont think it will randomly scan deeply into module directories. I recommend moving this file into your .drush folder and clearing the cache, then trying from your site folder again. Eg,

  • cp ./drealty/drush/drealty.drush.inc ~/.drush
  • drush cc drush
  • cd YOUR_DRUPAL_PROJECT/sites/all/modules
  • drush -u=admin -d rets-import
  • This worked thank you very much! Is this a bug in DRealty module that should be reported? – iewebguy Mar 24 '15 at 17:00
  • 1
    it's not a bug persay. Drush support is optional. Drush's scanning behavior is documented within drush .... if anything it could use a mention in their README.txt or INSTALL.txt. If you want to open an issue for them on the matter it probably wouldn't be a bad idea. – tenken Mar 24 '15 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.