I know how to attach Glossary mode into View page, based on setting here. I have tried to attach this mode into one of my block, but it does not seem to work. Is there a solution that work for block with Glossary mode?

--- Update on March 28, 2015 ---

I fixed by adding a View page(then I disable this) and that Glossary mode just work fine on block, except it will disappear once a letter is clicked. I found a solution about this issue on Drupal 6. Does anyone know how to fix this on Drupal 7?

1 Answer 1


Found the step by step correct setting from here.

  1. Create a view with page to show desired content type (PS: you must create a view page, event you only use the view block)
  3. add content title
  4. Select this page override
  5. Select Provide default value and type fixed value

  6. Enter "a" for default display only "a" word containing content and enter "all" for default display "all" content

  7. select Specify validation criteria:Basic
  8. Click More AND check Glossary mode option
  9. Set Character limit 1
  10. save
  11. Use Ajax "yes"

Now add a attachment


  2. add content title

  3. Select this attachment override

  4. Click Display a summary
  5. Click Unformatted and check Display items inline, under Separator add "-" or "|"
  6. Set Attach to: page From ATTACHMENT SETTINGS
  7. Set Inherit contextual filters: NO From ATTACHMENT SETTINGS
  8. Use Ajax: Yes
  9. Now save and run the page

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.