0

I have a normal website, where I override the views templates for one view. When I go into the views UI, and check Other->Theme , it clearly indicates it is using the custom templates. But when I check the website, the templates are not used.

I think this happened when activating cache. (Yes, I cleared it already, and many times).

I saw that suddenly, altough the theme still worked, it got deactivated. So I reactivated it, but still the views templates are not used in frontend.

Can anyone please shed a light on this?

It is only one template file that doesn't work anymore.

screenshot

  • 1
    Are you working on your own in a single environment? Or is your development environment perhaps sharing a database with a colleague, or with a test/acceptance/production server? – marcvangend Nov 11 '11 at 16:11
2

I have not experienced this, but have a theory. The default views that come with the module can be restored to their original condition so your problem may relate to the "special' nature of these views. Try cloning the view and making your modifications to the clone.

  • It worked for 1 second, the the tpl file is ignored again – Nealv Nov 11 '11 at 14:49
  • This sounds like it could be a bug. Have you gone to Drupal.org and reviewed bug reports for similar issues? I would suggest you report this to the Views module folk and let them respond, they're pretty good at responding to bug reports. – Ashlar Nov 11 '11 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.