1

Quite simply, I enable the super common "Views" module, and on Save nothing but a white page happens. On a refresh (Where I agree to the form resubmission) the modules page comes back just fine.

Then I click the "Run cron" link, and that is also blank, and never shows anything else or redirects.

Visiting cron.php by itself, also blank.

I've seen some solutions, such as increasing php's memory_limit and mysql's max_allowed_packet, but neither have done anything.

Everything runs optimally again the moment I disable Views.

Some info:

Web server: nginx/1.4.6
PHP: 5.5.9
PHP memory limit: 256M
Drupal: 7.35

I've never had this problem before, especially with Views

  • Check your server error log, there may be more debug info there. – David Thomas Mar 28 '15 at 3:49
  • @DavidThomas 2015/03/30 19:17:50 [error] 10141#0: *13601 FastCGI sent in stderr: "PHP message: PHP Fatal error: Cannot redeclare class view in /var/www/[redacted]/sites/all/modules/views/includes/view.inc on line 19" while reading response header from upstream, client: 208.91.114.4, server: [redacted], request: "GET /admin/structure/block HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "[redacted]", referrer: "[redacted]" – RedactedProfile Mar 30 '15 at 23:20
1

Sounds like either:

  1. You have two copies of the Views module enabled somehow.
  2. You have a problem with your server configuration in relation to op-code caching.

Check your "system" table in the database with:

SELECT name, filename, status FROM system WHERE name = 'views';

Check the results are as expected for your install.

For the op-code cache issue, check this thread:

Cannot redeclare class view, updating to PHP5.5

https://www.drupal.org/node/2066561

It may be a problem with using multiple op-code caching methods, or xcache conf issue.

  • Hi thank you! The query only returned the one result views | sites/all/modules/views/views.module | 1 but yeah even clearing out the views module and jumping around a bunch of versions, they all produce the same result :| – RedactedProfile Mar 31 '15 at 20:42
  • 1
    The cache config did it vi /etc/php5/fpm/php.ini and uncommenting opcache.enable=0 worked (after restarting php5-fpm of course) – RedactedProfile Mar 31 '15 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.