I've just updated to MAMP 3.1, and am running Yosemite 10.10.3 (public beta). Since updating, I cannot perform any commands using Drush.

I have:

  1. sim-linked from /var/mysql and also /var/lib/misql into /Applications/MAMP/tmp/mysql/mysql.sock
  2. Tested the connection to the database using Sequel pro;
  3. Tested the connection using a standard PHP script.

In both 2 and 3 above, I used the direct path to the MAMP socket, and also the one in /var/mysql/mysql.sock

So can anyone think of a reason why this won't work?

Thanks for those suggestions. I inadvertently stumbled on a solution. I'm no expert here, so there could (and probably are) reasons why this isn't a good idea but I'll share it anyway.

I simply created a sim-link by doing the following: cd /tmp sudo ln -s /Applications/MAMP/tmp/mysql/mysql.sock mysql.sock

Worked like a charm.

2 things seem to work:

  • setting your mysql / pgsql to 127.0.0.1 in your settings.php file instead of localhost (if that was the case)
  • reverting to Drush 6

But this is still an issue on MAMP 3.1 + Drush 7 that needs to be resolved.

  • Interestingly, I only updated to Drush 7 in the first place because the update to MAMP 3.1 caused my Drush 6 setup to stop working. – user23795 Apr 2 '15 at 23:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.