0

Problem: Items are not grouping correctly.

The Setup: I'm working in Views and trying to customize it to display items grouped by a taxonomy term field called 'Event Type'. Furthermore I'd like them to be grouped WITHIN each taxonomy term grouping by Category (in a specific order). Each resource has both an event type and category. There are three event types: timely event, quick study, and deep dive. There are 10 categories: webinar, conference, articles, etc. 3 of those categories are also in 'Timely Events'. 4 of them are in 'Quick study'. The other 3 are in 'deep dive'.

My categories are setup to be ordered. The category field is a field list and has key/value pairings to match what I want. So, for example:

1|Webinar
2|conference
3|Workshop
4|Articles
etc.

Note that webinar, conference, and workshop will the 3 under 'timely events' and that's why they're ordered that way. The next four starting with Articles are under 'Quick Study', etc.

So I have it structured the way I want it to appear in the view already. And I want the view to reflect this by displaying something like this:

Timely Events
All webinars listed
All workshops listed
All conferences listed

Quick Study
All Articles listed
All [other 3 categories in order as set in the key/value pair above]

Deep Dive
Same as the others

Then in the view itself I have set Format > Unformatted List > Settings (Grouping field Nr. 1: Content: All taxonomy terms).

In Fields I have 'all taxonomy terms' set as the first field, with the following settings: 'exclude from display' and 'limit terms by vocabulary' > set to 'event-type'.

Under 'Content: all taxonomy terms' in 'Fields' I'm displaying icon, price, title, event dates, and body.

My filter criteria is set to published, type=resource, search terms and other exposed filters.

My sort criteria is set to Category (asc), event-dates asc, content: title.

The Result:

    Timely Events (header)
    All webinars listed in the correct order.

    Deep Dive
    All certificates listed in the correct order.

    Timely Events (again - why?)
    All conferences listed in the correct order.

    Quick Study
    All articles listed in the correct order.

    Timely Events (yet again)
    All workshops listed in the correct order.

My Question for you: How can I get my results to display so that the headers (event type) display ONLY ONCE followed by each of the categories in that header in the order in which I've set them in the key/value pairing in the field list?

It should be like this:

Timely events (header)
all webinars
all conferences
all workshops

Quick Study (header)
all articles
etc.

Deep Dive (header)
all certificates
etc.

And that's it.

Anyone have any idea how to correct my grouping here?

0

Of course. Since I have 10 sub-categories and I'm ranking them by 'key' number 10 is displaying AFTER number 1 and then 2, 3, 4, 5, 6, 7, 8, 9. That's why it's returning the incorrect results. 10 should be named something else like 99 so it comes after 9.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.