1

How to delete these tables "views_data_export_index_%" create by views data export module, the database getting huge.

2 Answers 2

1

The short answer here is to disable & uninstall the Views Data Export module. Once you uninstall it, all the tables should be wiped out. The longer answer is why worry so much about so much size? The views_data_export_object_cache seems like it should contain large chunks of data that can be cached from previous exports.

2
  • Because it takes huge size and by role it takes long time when import the database contains these unneeded tables, i have made better solution for that which excluding this specific table data "views_data_export_object_cache" which takes terrific size :) through Backup & Migrate tool Apr 7, 2015 at 10:43
  • I see. Good call. Backup & Migrate is an excellent module.
    – Shawn Conn
    Apr 7, 2015 at 16:46
0

Uninstalling the module is the brute force option since it means losing all settings data also. You can delete the entries of the database table views_data_export_object_cache via phpMyAdmin. Make sure the data is not in use.

I once had a lot of entries in that table after applying a buggy patch to Views Data Export. These entries could not get deleted by cron, even after DRUPAL_MAXIMUM_TEMP_FILE_AGE which is set to 6 hours on a standard install of Drupal. To get rid of the corresponding Watchdog entries I deleted all entries in the views_data_export_object_cache.

Regarding your concerns about Backup & Migrate, you can exclude tables from being exported by backup_migrate by going to admin/config/system/backup_migrate/settings/profiles and editing the standard or any custom profile. Here you can exclude tables or the data in tables from being exported. Some of the tables (cache data mostly, but also watchdog or accesslog) are excluded by default. It's a good idea to have a quick look at these settings whenever you installed contrib modules that come with an own cache data table.

1
  • The concern is raised above my comment for the moment. It's not my fault that one cannot comment on comments with a rep < 50 Pts. Feel free to delete or edit my comment.
    – upunkt
    Feb 28, 2017 at 11:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.