1

I am running a local copy of my site on Acquia Dev Desktop and everything is working fine.

The site is set to enforce SSL connection when logging in to the sitename.com/admin page. However, since it is now installed on my localhost, it does not have an SSL certificate and throws the error like so:

SSL connection error
Unable to make a secure connection to the server. This may be a problem with the server,
or it may be requiring a client authentication certificate that you don't have.
Error code: ERR_SSL_PROTOCOL_ERROR

What can I do in order to get around this, and log in to my page administratively?

  • How are you going about forcing the ssl on login? Module or .htaccess etc? – webhorse Apr 3 '15 at 16:52
2

DevDestop now supports this. https://docs.acquia.com/dev-desktop2/sites

Acquia Dev Desktop now provides simulated HTTPS support using a self-signed SSL certificate, which supports local testing and development of websites that rely on SSL. Learn more.

Just download a new version of DevDesktop. I'm currently on Version 2, Control panel rev: 032976b and have it working with sites that use SSL.

2

On the Config settings from Acquia Dev Desktop >> Preference >> Config:

Now Select Apache Module (mod_php) and hit OK Button. That's All the SSL Connection Error has Fixed.

1

DevDesktop doesn't have mod_ssl included in its version of Apache.

The only way to go about it is to disable the site configuration that enforces SSL. If it's .htacess, you can edit the root .htaccess file to remove the HTTPS redirect rules. If it's a module like securepages, you can disable it directly in the system database ("UPDATE system SET status = 0 WHERE name = 'securepages' AND type = 'module' ), or better, use Drush to disable it from the console (e.g. "drush dis securepages").

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.